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Installing and Configuring Virtual machines

Configure a Virtual Network

Before anything else, our first step should be to create a virtual network for use by our virtual
machine. We can accomplish this by opening VMware Fusion and navigating to the
“Preferences...” tab from the drop-down menu.

VMware Fusion File Edit View Virtual Machine Window Help

Preferences...

Buy Now or Enter License...
Check for Updates...

Within Preferences, navigate to the Network tab and click the lock in the bottom-left corner to
make changes. Our settings for this network will be a Subnet IP of 192.168.50.0/24 (subnet
mask of 255.255.255.0). We will also be ticking “Allow virtual machines on this network to
connect to external networks using NAT” (MacOS Big Sur). Correct settings are shown below:

@ Network

B A ® O

General Keyboard & Mouse Display Default Applications Network Feedback

Internet Sharing

. The virtual machine using this configuration will use a custom
Share with my Mac network connection.
Bridged Networking Allow virtual machines on this network to connect
Autodetect to external networks (using NAT)
Wi-Fi IPv6 Prefix:
Custom Port Forwarding
Private to my Mac Host Port Type VM IP Address Description
IAS-Online
eng2

CMP-Network
CMP-Network2
vmneté +

Subnet IP: | 192.168.50.0|
Subnet Mask: 255.255.255.0

+[- ?
Require authentication to enter promiscuous mode

E_i Click the lock to prevent further changes
Revert Apply



Click “Apply” to save the settings, and then click the lock again to prevent further changes.

Installing Windows Server 2019 VMs

Open up VMWare Fusion Pro and click the + in the top left corner.
0O +v
New... N

= <>g<> New Boot Camp...
2 he @— Migrate Your PC...
B v (S Import...
=R (C] Folder
9 VB o sean
T ANsivic vernus 7 — o,

Click “Continue”, and then press the following button to select your Windows Server ISO file.

Use another disc or disc image...

Click continue and enable Easy Install. Put in credentials to use on the Windows Server VMs, as
well as a license key if you have one. Select Windows Server 2019 Standard from the dropdown
list.

Microsoft Windows Easy Install

With Easy Install, VMware Fusion will use the information provided here to automatically install
Windows Server 2019 from your installation disc and install drivers to optimize your virtual
machine.

Choose Disc Configuration Finish
or Image

Use Easy Install

Account Name: Thomas Ayres
Account Type: Administrator
Password: eeeeecccece optional)

Confirm Password:  eeeeescese

Windows Product Key:
Language: English (United States)
Windows Server 2019 Standard

Make your home folder accessible to the virtual machine

The virtual machine can Read & Write e

? Cancel Go Back



Continue through until you see a screen with your VM details all on one page. Click the
following button, and then save the VM as “NLB-serverl”.

Customize Settings

Within the settings, we need to set up a second NIC, so click “Add Device” in the top right of the
window.

Add Device...

Click “Network Adapter”.

Network Adapter

Scroll down and select the virtual network that we made earlier.

® vmnet6 (o)

Now you should have two NICs in the main settings. Click on the pre-configured NIC that was
there already and repeat the above step, so that now both NICs are set to the same “vmnet6”
network.

KEIMovdapI€ vevices

:\ \l‘ @

Network Network
Adapter Adapter 2



You may now begin installation of Windows. Boot up the VM and wait for the following window
to finish.

(S

¢ Windows Setup

Installing Windows

Status

Copying Windows files (0%)
Getting files ready for installation
Installing features

Installing updates

Finishing up

Repeat the same steps to create a second Virtual Machine named NLB-server2.



Set up Servers

Set Hostnames

After your Server 2019 VMs are up and running, log in and Server Manager should pop up.
In Server Manager, navigate to Local Server:

. == PROPERTIES
22 Dashboard . For WIN-FE2809409V3

i Local Server
Computer name WIN-FE2809409V3

BE All Servers

Workgroup WORKGROUP

Click on the blue text next to “Computer name”. It will bring up properties. Click the following:

To rename this computer or change its domain or
workgroup, click Change.

Change...

Enter the respective name for the vm: “NLB-server1” or “NLB-server2”.



Set Static IP Addresses

Still under “Local Server”, in the same box as Computer Name, there will two areas for your NIC
cards. Click the blue text next to them to configure.
Ethernet0 |[Pv4 address assigned by DHCP, IPv6 enabled

Ethernet1 IPv4 address assigned by DHCP, IPv6 enabled

A window will pop up. Navigate to properties for both, one at a time:

. . Ethernet0 . . Ethernet1

n\,"; Network =  Network
@ Intel(R) 82574L Gigabit N G Disable igabit Network ...
Status
Diagnose

G Bridge Connections

Create Shortcut
Delete

Rename

O AD

Properties

Uncheck the box for IPv6 and click on the text for IPv4. Select properties.

e e e

R Intemet Protocol Version 4 (TCP/IPvd)

] . Microsoft Network Adapter Multiplexor Protocol

2 Microsoft LLDP Protocol Driver

O 4 Intemet Protocol Version & (TCP/IPvE) W

£ >
Install... Uninstall Properties

-

Select the following settings for all NICs on both serverl and server2, changing only the “IP
address” field as follows:

NLB-serverl Ethernet0/1: 192.168.50.100/192.168.50.101

NLB-server2 Ethernet0/1: 192.168.50.200/192.168.50.201



Internet Protocol Version 4 (TCP/IPv4) Properties X

General

You can get IP settings assigned automatically if your network supports
this capability, Otherwise, you need to ask your network administrator
for the appropriate IF settings,

() Obtain an IP address automatically
(@) Use the following IP address:

IP address: | 192 . 168 . 50 . 100 |
Subnet mask: | 255 , 255 , 255 . O |
Default gateway: | 192 .168. 50 . 1 |

Obtain DMNS server address automatically

(@) Use the following DNS server addresses:

Preferred DNS server: | 192 . 168 . 50 . 100 |
Alternate DNS server: | 192.168. 50 . 1 |
[[]validate settings upon exit Advanced. .

Cancel

Set up Load Balancer Role

In the top right of Server Manager, select Manage > Add Roles and Features

| I' \ELEL[S [ee] S View Help

Add Roles and Features

Remove Roles and Features

Add Servers




Click Next, and then select Role-based or feature-based installation. Click Next.

DESTINATION SERVER

Select installation type NLB-server

Before You Begin

Installation Type

Server Selection

Select the installation type. You can install roles and features on a running physical computer or virtual
machine, or on an offline virtual hard disk (VHD).

® Role-based or feature-based installation
Configure a single server by adding roles, role services, and features.

O Remote Desktop Services installation
Install required role services for Virtual Desktop Infrastructure (VDI) to create a virtual machine-based
or session-based desktop deployment.

NLB-serverl/NLB-server2 will be the default here. Click next.

DESTINATION SERVER

Select destination server NLB. server?

Before You Begin
Installation Type
Server Roles

Features

Select a server or a virtual hard disk on which to install roles and features.

® Select a server from the server pool
O Select a virtual hard disk

Server Pool

Filter: |

Name IP Address Operating System

NLB-server1 192.168.50.100... Microsoft Windows Server 2019 Standard

1 Computer(s) found

This page shows servers that are running Windows Server 2012 or a newer release of Windows Server,
and that have been added by using the Add Servers command in Server Manager. Offline servers and
newly-added servers from which data collection is still incomplete are not shown.

Under the roles, navigate down and select this option:

BRWeb Server (1IS)

Click Add Features



Add Roles and Features Wizard

Add features that are required for Web Server (1IS)?

The following tools are required to manage this feature, but do not

have to be installed on the same server.

4 \\eb Server (lIS)
4 Management Tools
[Tools] IIS Management Console

Include management tools (if applicable)

Add Features

Cancel




On the next screen, browse down to find Network Load Balancing and check the box. Click Add
Feature.

Bz Add Roles and Features Wizard — 0O % |:
Select features N et |

[, Add Roles and Features Wizard X

Select one or more features to ins
Add features that are required for Network Load

Features 3
Balancing?

PPTy TP ———

IP Address Manégememt 0 The following tools are required to manage this feature, but do not
ISNS Server service

have to be installed on the same server.

Man_agement QData 1S E4 4 Remote Server Administration Tools
Media Foundation 4 Feature Administration Tools

! Message Queuing [Tools] Network Load Balancing Tools
Multipath 1/O

b MultiPoint Connector
Network Virtualization
Peer Name Resolution Prg
Quality Windows Audio V
RAS Connection Manager
Remote Assistance
Remote Differential Comp

b Remote Server Administra

RPC over HTTP Proxy Include management tools (if applicable)
Setup and Boot Event Col
Simnle TCP/IP Services {Add Features | | Cancel |

On the confirmation screen, check the “restart the destination server automatically...” box, and
then click yes.

[} — e
Bs; Add Roles and Features Wizard —

. . . . DESTI
Confirm installation selections
Before You Begin To install the following roles, role services, or features on selected server, click Install.
Installation Type Restart the destination server automatically if required
Server Selection Optional features (such as administration tools) might be displayed on this page because

been selected automatically. If you do not want to install these optional features, click Pre

Server Roles their check boxes.

Features Add Roles and Features Wizard
Web Server Role (IIS)
Role Services ii If a restart is required, this server restarts automatically, without
Confirmation / & additional notifications. Do you want to allow automatic restarts?
Yes No
Web Server
Common HTTP Features
Mafa.ds Mamin mea +

Paydirt. Hit Install and wait.



Install

Repeat this process for both Virtual Machines.

Set Admin Password (NLB-server1)

Navigate to the Tools dropdown on the right top side and select computer management.

v @ I I'A Manage Tools View Help

Active Directory Administrative Center

Active Directory Domains and Trusts

Active Directory Module for Windows PowerShell
Active Directory Sites and Services

Active Directory Users and Computers

ADSI Edit

Component Services

Computer Management

Defragment and Optimize Drives

Disk Cleanup

Friramt VimniAr

On the right side, select Users under Local Users and Groups

& Computer Management (Local)
v '[[’,_!; System Tools
"E}' Task Scheduler
@ Event Viewer
a2| Shared Folders
v &% Local Users and Groups
| Users
| Groups

|:"E'|\"| | p N




Find the Administrator account in the middle drop down list > right click > Set Password

Built-in account for administering ..

Set Password...

&j Default A user account managed by the sy...
&jGuest All Tasks > Built-in account for guest access t..
Bl Thoma:

Domain Controller (NLB-server1)

We need to add the Active Directory service. In the top right of Server Manager select Manage
> Add roles and features

| I' \ELEL[S Tools View Help

Add Roles and Features

Remove Roles and Features

Add Servers

Click next, then select the default shown below:

DESTINATION SERVER

Select installation type NLB-server

Before You Begin Select the installation type. You can install roles and features on a running physical computer or virtual

machine, or on an offline virtual hard disk (VHD).
Installation Type

. ® Role-based or feature-based installation
Server Selection
Configure a single server by adding roles, role services, and features.

(O Remote Desktop Services installation
Install required role services for Virtual Desktop Infrastructure (VDI) to create a virtual machine-based
or session-based desktop deployment.



Click next and select NLB-serverl (default). Click next.

DESTINATION SERVER

Select destination server LB ~arpert

Before You Begin Select a server or a virtual hard disk on which to install roles and features.

Installation Type @® Select a server from the server pool
Server Roles Server Pool
Features
Filter: |
Name IP Address Operating System

NLB-serverl 192.168.50.100... Microsoft Windows Server 2019 Standard

1 Computer(s) found

This page shows servers that are running Windows Server 2012 or a newer release of Windows Server,
and that have been added by using the Add Servers command in Server Manager. Offline servers and
newly-added servers from which data collection is still incomplete are not shown.

| < Previous | | Next > | Install

Scroll down and select the Active Directory Domain Services role from the list. Check the box,
then select Add Features

Before You Begin Select one or more roles to install on the selected server.

Installation Type Roles Description

Server Selection B el it Sl P it e Active Directory Certificate Services
] Active Directory Domain Services (AD CS) is used to create certificatior
] Active Directory Federation Services authorities and related role services
Features . - : . .
[] Active Directory Lightweight Directory Services
[] Active Directory Rights Management Services
[[] Device Health Attestation

that allow you to issue and manage
certificates used in a variety of
applications.



=, Add Roles and Features Wizard X

Add features that are required for Active Directory
Domain Services?

You cannot install Active Directory Domain Services unless the
following role services or features are also installed.

[Tools] Group Policy Management
4 Remote Server Administration Tools
4 Role Administration Tools
4 AD DS and AD LDS Tools
Active Directory module for Windows PowerShell
4 AD DS Tools

[Tools] Active Directory Administrative Center
[Tools] AD DS Snap-Ins and Command-Line Tools

Include management tools (if applicable)

Add Features Cancel

Click Next all the way through until the Confirmation page. Check the Restart box and then click
yes. Click install.



A \JLITTITTT T ITTIoOLUIIULIVIE T OCIC LIV 1O NLB-

Before You Begin To install the following roles, role services, or features on selected server, click Install.
Installation Type Restart the destination server automatically if required
Server Selection Optional features (such as administration tools) might be displayed on this page because they hz

Server Roles

Features
AD DS

been selected automatically. If you do not want to install these optional features, click Previous tc
their check boxes.

Active Directory Domain Services

Remote Sanuar Adminictrati Taanlc
Add Roles and Features Wizard

Role

If a restart is required, this server restarts automatically, without
L additional notifications. Do you want to allow automatic restarts?

Yes No

Back on the main interface of Server Manager, you will find a flag with a yellow exclamation
symbol right next to the Manage button up top. Click it for a drop-down menu. Click the blue
“Promote this server...” text.

LB-
'OF

1 Post-deployment Configura... |
Configuration required for Active Directory Domain
Services at NLB-SERVERT
Promote this server to a domain controller

A | T R S T | [T

In the wizard that pops up, select Add a new Forest. | am going to name this “NLB.local”.



Deployment Configuration e

Deployment Configuration

Domain Controller Options

Select the deployment operation

(O Add a domain controller to an existing domain
Additional Options

(O Add a new domain to an existing forest
Paths ® Add a new forest

Review Options
Specify the domain information for this operation

Prerequisites Check
Root domain name: NLB.local I

On the next screen, set the DSRM password:

. . TARGET SERVER
Domain Controller Options NLB-server?
Deployment Configuration ) )
Select functional level of the new forest and root domain
Domain Controller Options .
) _ ) "
DNS Options Forest functional level: | Windows Server 2016
Additional Options Domain functional level: | Windows Server 2016 &
Paths Specify domain controller capabilities
BIET BRI STE Domain Name System (DNS) server
Prerequisites Check + Global Catalog (GC)
Read only domain controller (RODC)
Type the Directory Services Restore Mode (DSRM) password
Password: |oo-oo--ooo
Confirm password: |uunono
More about domain controller options
| < Previous | | Next > | | Install ‘ | Cancel

Click through the rest of the screens, leaving them default. Install. Computer will restart.



Add NLB-server2 to domain

Within Server Manager navigate to Local Server, and click on the blue highlighted

“WORKGROUP” near “Workgroup”:
N - - -

i PROPERTIES

52 Dashboard For NLB-server2

i Local Server
- Computer name NLB-server2
Bi All Servers Workgroup WORKGROUP
ii File and Storage Services P
GRS
Windows Defender Firewall Public: On
Remote management Enabled

Click on Change...:

run vuiipule naiiie. NLD-S2I Vel £

Workgroup: WORKGROUP

To rename this computer or change its domain or

. Change...
workgroup, click Change.

erver 2|

Create Load Balancer (NLB-serverl)

Navigate to the NLB Manager from the Tools menu in the top right of the Server Manager
Dashboard. From this new window, select Cluster > New.

G Network Load Balancing Manager
File Cluster Host Options Help
gl New

Connect to Existing




Type in the host of NLB-serverl (192.168.50.100), and select the second NIC from the list
(192.168.50.101) and click next

Add Host to Cluster : Host Parameters

Priarty {unique host identifier): 1 w
Dedicated IP addresses
I[P address Subnet mask
152.168.50.101 25525562550
Add... Edit ... Remowve
Initial host state
Default state: Started "

[ ] Retain suspended state after computer restarts

< Back Mext = Cancel Help

Click next



Add IP Address X

(@) Add IPv4 address:

[Pv4 address: 192 , 168 . 50 . 5

Subnet mask: P55 . 255,255, 0
Add IPv6 address:

IPv6 address:

Generate IPvE addresses:

Linkdocal Site-ocal Global

] Cancel

Click OK. On the Cluster Parameters screen use www.nlbcluster.com for the Full Internet Name.
Set the operation mode to Multicast.



http://www.nlbcluster.com/

New Cluster : Cluster Parameters X

Cluster |P corfiguration

|P address: 192.168.50.5 e
Subnet mask: 250,255 .255. 0

Full Intemet name: www nibcluster com

Metwork address: 03-bfc0ad-3205

Cluster operation mode

() Unicast
(@) Mutticast

() IGMP multicast

< Back Mext = Cancel Help

Finish up and repeat the process by adding in the second NIC card of NLB-server2 by connecting
to 192.168.50.200 and selecting the 201 IP.

MLE-SERY Add Host To Cluster

- —



Set up IIS Site
HTML

Open up file explorer (folder on the taskbar at the bottom of the screen) and navigate to C:
using the bar up top.

¢ C:

Right click within this directory and create a new folder. Name it nlb.

Paste shortcut

Give access to >
New > Folder
Properties

Open up notepad using the search bar on Windows taskbar.

£ notepad

Add <h1>You have reached NLB-serverl</h1 for serverl, or <h1>You have reached NLB-
server2</h1> for server2.

File Edit Format View Help
<h1>You have reached NLB—sereP1</h1ﬂ

Click File > Save As, then navigate to the nlb folder. Save the file as index.html and set save type
to “All files”.

Move the nlb folder to inetpub > wwwroot. Delete anything that is not the nlb folder within the
wwwroot directory.

Set IIS Default

Navigate to the Tools drop down menu from the dashboard and select the 1IS Manager.



@ | I' Manage Tools View Help

._ Active Directory Administrative Center

Active Directory Domains and Trusts
Active Directory Module for Windows PowerShell
Active Directory Sites and Services
Active Directory Users and Computers
ADSI Edit

Component Services

Computer Management

Defragment and Optimize Drives

Disk Cleanup

DNS

Event Viewer

Group Policy Management

Internet Information Services (IIS) Manager

iCr O] lmidimd =

Select the server from the sidebar, and then double click on Default Document.

- ‘Eﬂ Start Page

- 83 NLB-SERVER1 (NLB\Thomas

V]

Default

Click on Add... on the far right and add nlb/index.html. Repeat this entire process on both
servers.



Add...

file. Set default documents in order of priarity. Disable
'@' Help
Mame Entry Type
nlb/index.html Local
Default.htm Local

Change the default Hosts file
On both servers, open notepad as administrator by right clicking. Within notepad, click File >
Open and navigate to %WinDir%\System32\Drivers\Etc.

Select the hosts file and open.

Add the following line to the bottom of the entire script, and save the document:

192.168.50.5 www.nlbcluster.com



http://www.nlbcluster.com/

Conclusion

All things said and done, if you navigate to www.nlbhosts.com on either server, the respective
page should reply. Here is a screenshot showing them side-by-side:

ese NI B 3

@ o & NLB-sorver2 a

(9
- o x
e llocuster com. & Search, o~
odusiercom
i . 3 I Dashboard - *
=
; You have reached NLB-serverl PR < prrsee— + &fsm o-
i i All servers & niodustercom
i " g Fi t
‘ iy 5 reandsc You have reached NLB-server2
i e XN
.
H
#
.
.
# # Cop
& #
& # Thi
& ®
# # Thi
E3 # ent
H ' be
# #® The
H * spa
s #
. 102.54,94.97 rhino.acme. com W source server # Add
& 38.25.63.10 X.acme.com # x client host # lin
M
# localhost name resolution is handled within DNS itself. # For example:
* 127.0.0.1 localhost "
# 13 § localhost * 192.54.94.97 rhino.acme.com # source server
* 38.25.63.19 X.acme. com # x client host
192.168.50.5 waw .nlbcluster.com
# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
11 localhost
192.168.50.5 www.nlbcluster. com
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